Frequently asked questions

Perguntas frequentes

Here you'll find answers to common problems when installing and using the browser component

Aqui você encontrará respostas para os problemas mais comuns para instalar e usar o componente

What is and why do I need to install it? O que é o e por que eu preciso instalá-lo?

is a browser component for using digital certificates in web pages, usually to perform digital signatures or user authentication. The operation you were performing on requires in order to give you access to your certificates. If you landed on the installation page of , you were probably peforming an operation on a website that uses it in order to give you access to your digital certificates.

O é um componente para navegadores que permite o uso de certificados digitais em páginas web, normalmente para realizar assinaturas digitais ou autenticação de usuário. A operação que você estava fazendo em requer o para lhe dar acesso aos seus certificados. Se você foi redirecionado para a página de instalação do , você provavelmente estava realizando alguma operação em um site que o utiliza para lhe dar acesso aos seus certificados.

While trying to use my certificate, the following error occurs: "The keyset is not defined" Ao tentar utilizar meu certificado, aparece o erro "O conjunto de chaves não está definido"

Applies to: Windows (any browser) with certificates stored on cryptographic devices (smartcards or USB tokens)

Aplica-se a: Windows (qualquer navegador) com certificados A3, ou seja, armazenados em dispositivos criptográficos como smart card ou token USB

If your certificate is stored in a USB token, try plugging the token into a different USB port. If your certificate is stored in a smarcard, try removing and inserting it again until the reader light stops flashing and stays on. Try also plugging the reader into a different USB port.

Caso seu certificado esteja armazenado em token USB, tente inserir o token em outra porta USB. Caso esteja armazenado em smart card, tente remover e inserir novamente o smart card até que a luz da leitora pare de piscar e fique constantemente acesa. Tente também trocar a leitora de porta USB.

If these solutions do not work, the problem might be the driver for the cryptographic device. A common mistake is to install the 32 bits version of the driver on a 64 bits operating system (for 64 bits operating systems, which are most common nowadays, always install the 64 bits version of the driver). We recommend that you uninstall the driver (e.g.: SafeSign, SafeNet) and install the latest driver corresponding to your cryptographic device and operating system. Please visit your Certification Authority's website in order to download the latest drivers.

Se o erro persistir, o problema pode ser no driver do dispositivo. Um erro comum é instalar o driver versão 32 bits em sistemas 64 bits (para sistemas 64 bits, que são maioria atualmente, sempre instale o driver 64 bits). Recomendamos a desinstalação do driver (SafeSign, SafeNet, etc) e instalação da última versão correspondente ao seu dispositivo criptográfico e sistema operacional. Acesse o site da sua Autoridade Certificadora para obter os drivers mais atualizados.

One of my certificates stored on a cryptographic device is not listed Meu certificado A3 (em smart card ou token USB) não é listado

Applies to: Certificates stored on cryptographic devices (smartcards or USB tokens)

Aplica-se a: Certificados A3, ou seja, armazenados em dispositivos criptográficos como smart card ou token USB

On Windows, this is usually due to not having installed the driver for the cryptographic device or having the wrong driver installed. A common mistake is to install the 32 bits version of the driver on a 64 bits operating system (for 64 bits operating systems, which are most common nowadays, always install the 64 bits version of the driver). We recommend that you uninstall the driver (e.g.: SafeSign, SafeNet) and install the latest driver corresponding to your cryptographic device and operating system. Please visit your Certification Authority's website in order to download the latest drivers.

No Windows, esse problema geralmente ocorre porque o driver do dispositivo criptográfico não está instalado ou porque o driver errado está instalado. Um erro comum é instalar o driver versão 32 bits em sistemas 64 bits (para sistemas 64 bits, que são maioria atualmente, sempre instale o driver 64 bits). Recomendamos a desinstalação do driver (SafeSign, SafeNet, etc) e instalação da última versão correspondente ao seu dispositivo criptográfico e sistema operacional. Acesse o site da sua Autoridade Certificadora para obter os drivers mais atualizados.

On Mac OS and Linux, this is usually due to not having any cryptographic devices enabled on . Please follow the steps below in order to enable one or more cryptographic devices on :

No Mac OS e no Linux, esse problema geralmente ocorre porque não há nenhum dispositivo criptográfico habilitado no . Por favor siga os passos abaixo para habilitar um ou mais dispositivos criptográficos no :

  1. Click the icon located on the browser window's upper right corner Clique no ícone do situado no canto superior direito do navegador
  2. Click the button "Crypto devices (PKCS #11) ..." Clique no botão "Dispositivos criptográficos (PKCS #11)..."
  3. Check the option that corresponds to your cryptographic device Marque o módulo correspondente ao seu dispositivo criptográfico

While trying to use my certificate, the following error occurs: "Invalid algorithm specified" Ao tentar utilizar meu certificado, aparece o erro "Algoritmo inválido especificado"

Applies to: Windows (any browser) with certificates stored on cryptographic devices (smartcards or USB tokens)

Aplica-se a: Windows (qualquer navegador) com certificados A3, ou seja, armazenados em dispositivos criptográficos como smart card ou token USB

This error usually occurs when the driver for the USB token or smartcard is out of date. Please visit your Certification Authority's website in order to download the latest drivers for your cryptographic device.

Esse erro geralmente ocorre quando o driver do token USB ou smart card está desatualizado. Acesse o site da sua Autoridade Certificadora para obter a última versão do driver correspondente ao seu dispositivo.

While trying to use my certificate, the following error occurs: "Error while signing with keychain" Ao tentar utilizar meu certificado, aparece o erro "Error while signing with keychain"

Applies to: Mac OS (any browser) with certificates stored on keychain, that is, software certificates (does not apply to certificates stored on smartcards or USB tokens)

Aplica-se a: Mac OS (qualquer navegador) com certificados armazenados no keychain, ou seja, certificados A1 (não ocorre com certificados em smartcard ou token USB)

This error occurs due to a specific condition present in certain Mac OS environments. A workaround is described in the steps below:

Esse erro é decorrente de uma condição específica presente em determinados computadores com Mac OS. Para contorná-la, siga os passos abaixo:

  1. Press Command + Space Pressione Command + Barra de espaço
  2. Type Keychain Access and press return Digite Keychain Access e pressione return
  3. On the left panel, on the Keychains section, click the login item No painel à esquerda, na seção Keychains, clique no item login
  4. Still on the left panel, on the Category section, click the Certificates item Também no painel à esquerda, na seção Categoria, clique no item Certificados
  5. On the central panel, find the certificate you wish to use No painel central, identifique o certificado que deseja utilizar
  6. Expand the certificate by clicking the arrow at the beggining of the line Expanda o certificado clicando na seta no início da linha
  7. Double click the certificate key Dê um duplo clique na chave do certificado
  8. On the Access Control tab, select the option Allow all applications to access this item Na aba Controle de Acesso, marque a opção Permitir que todos os aplicativos acessem este item
  9. Click the button Save Changes Clique no botão Salvar Alterações

The setup of the application fails with the message "This application requires .NET Framework 4.0 or 4.5. Please install the .NET Framework then run this installer again." A instalação do aplicativo do no computador falha com a mensagem "Este aplicativo necessita do .NET Framework 4.0 ou 4.5. Por favor instale o .NET Framework e execute este instalador novamente."

Applies to: Windows XP and sometimes Vista or 7 (any browser)

Aplica-se a: Windows XP e, às vezes, Vista ou 7 (qualquer navegador)

Please click the link below to install the .NET Framework 4 Client Profile:

Por favor clique no link abaixo para instalar o .NET Framework 4 Client Profile:

https://www.microsoft.com/en-us/download/details.aspx?id=24872

https://www.microsoft.com/pt-br/download/details.aspx?id=24872

Afterwards, reboot your PC and try installing again.

Após a instalação, reinicie o seu PC e tente novamente instalar o .

What browsers are compatible with ? Quais navegadores são compatíveis com o ?

is supported on the following browsers:

O é suportado nos seguintes navegadores:

Do I need to uninstall Java to use ? Preciso desinstalar o Java para utilizar o ?

No. It is not necessary to uninstall Java.

Não. Não é necessário desinstalar o Java.

My problem is not listed here, what can I do? Estou encontrando um problema diferente dos citados acima, o que posso fazer?

We suggest you try using a different browser. is available for:

Recomendamos que você tente utilizando um navegador diferente. O é compatível com: